Get an idea on the requirements needed to effectively run this plugin with your online store.

WooCommerce

Point of Sale is a WooCommerce extension, therefore, WooCommerce is required. The WooCommerce plugin is free and can be downloaded by going to Plugins > Add New and searching for “WooCommerce”.

Products

This plugin does not allow you to create and publish products from the register, therefore, existing products are required.

You can add custom products to the order but the information for that product will not be saved to the database. It will be purely added to the order.

We recommend you have products that are imported and entered in correctly.

REST API

In order for the register to communicate with the WooCommerce database, it needs to use the REST API which is built into WooCommerce.

  • Go to WooCommerce > Settings > API and enable the REST API.
  • If you have not got REST API enabled, the register will not load as the products will not load.

Internet connection

An internet connection is required to keep orders in sync, customers up to date and of course payments processed with your gateway.

Should you need to use this register offline, we do have an offline mode.

Reliable browser

The debate to which browser to use has always been ongoing. We use a combination of Safari, Chrome and Firefox when developing and testing the plugin.

The important feature is IndexedDB, this allows the products to be saved in the browsers cache so instant scanning is possible.

Click here to view a list of browsers supporting this.

Caching

If you are intending to use the Point of Sale with syncing ability then do take into consideration that caching is turned off for the page the register loads on.

Caching may be managed by a plugin you have installed or your domain may have a backend configuration.